Search by voice
Windows
Mac
Windows
Log in / Sign up
Windows
›
Tags › time
Featured
Time
Software
Relevance
Popularity
Rating
NI LabVIEW Run-Time Engine
free
4,703
National Instruments Corporation
Ni LabVIEW Run-Time Engine is a free program that offers you full support for executables. The Ni LabVIEW Run...
Ni LabVIEW Run-
Time
Engine is a free program...The Ni LabVIEW Run-
Time
Engine
Shutdown Timer
2,439
RT Softwares
Shutdown Timer can auto Shutdown pc, Restart pc, Log Off current signed on user after 1 to 120...
Window Displays current system
time
as well
Mortimer Beckett And The Time Paradox
1,847
Paprikari
If you thought you'd heard the last of Mortimer Beckett after he managed...
If you thought you'd heard the last of Mortimer Beckett after he managed to evict the ghosts
Absolute Time Server
1,378
FlexibleSoft Co.
Absolute Time Server is a full-fledged time server capable of running...
a full-fledged
time
server capable...and performs various
time
synchronization tasks
Free Timer
free
1,276
Comfort Software Group
Avid multitaskers, let's bid farewell to running out of time unnoticed with Free Timer! This nifty, tiny, and easy...
to running out of
time
unnoticed...its adaptability across different
time
scales
Advanced Time Synchronizer
528
Southsoftware.com
This is a general-purpose and light weight computer time synchronizer...
supports three
time
synchronization protocols...Advanced
Time
Synchronizer adds
time
protocols
Time Attendance
free
339
O2Run Systems
Time and Attendance software from O2Run Systems is a versatile software...
Time
and Attendance...costs while you save
time
and money by reducing
Time Tracker
231
Pocket Tutor
Time Tracker teaches young children how to tell time using an analog clock...
the "current"
time
in conjunction...the "configurable"
time. Time
Tracker uses dynamic
Net Time Server & Client
202
Han-soft Corporation
The time synchronization application synchronize your PC's system clock or all PC's system clock in your LAN using...
(SNTP-RFC2030, SNTP-RFC4330),
Time
protocol(RFC868), UnixTime protocol
Work Time Monitor by Roi Buchnik
free
128
Roi Buchnik
Work Time Monitor is a free and terribly useful application that will record every second of your working...
these settings, Work
Time
Monitor can start logging...days and
time
, the average work
time
, the extra
Cobra 11 - Crash Time
112
SYNETIC GmbH & Co. KG.
Fans of arcade-racing-action watch out, Crash Time hits the fast lane...
action watch out, Crash
Time
NTP Time Zone Clock
free
85
Galleon Systems
NTP Time Zone Clock to show you the correct local time of 300 cities worldwide...
PC this NTP
Time
Zone Clock...With this NTP
Time
Zone Clock...know the local
time
in New York
Rocket.Time
free
73
Rocket Software
The Rocket.Time programs offer a range of time synchronization products that allow you to put every computing...
Additionally, synchronized
time
across your organization...workplace. The Rocket.
Time
programs
SNV Timer
73
Nikolay Sukhorukov
Excellent analog Timer & Alarm & Clock & Planner & Calendar & Notepad. Simultaneous execution of a great...
specifying an actuation
time
by simple...number of executions and a
time
unit: days
Easy Time Control
free
61
Easy Trinity
Easy Time Control allows employees to clock in and out using their application...
Easy
Time
Control allows employees...or individual budget. Easy
Time
Control is designed
FF File Time
free
55
Fast Forward Projects
FF File Time is a program that allows you to easily modify the time stamps of any file on your computer...
). Besides setting the
time
to a fixed...certain amount of
time
from any
time
stamp
Cryptex of Time
40
Bigfish Games
Cryptex of Time is a puzzle game. It consists of many riddles, which the player...
Cryptex of
Time
is a puzzle game...is that Cryptex of
Time
is not an interesting
Mario Time Race
free
20
Free Kids Games
Mario Time Race is free game designed for kids. The objective of the game is for players...
Mario
Time
Race is free game...isn't extended enough. Mario
Time
Race
User Time Administrator
13
1st Security Software Center
User Time Administrator lets you specify when exactly and how long the computer...
or online. User
Time
...specified dates. User
Time
Administrator can record
ALGE Time.NET
free
5
ALGE-TIMING GmbH
ALGE Time.NET is a free evaluation software for ALGE devices. Currently supported devices are...
The command „request
times
“ works...the transmitting of the
times
1
2
3
4
5
6
7
8
…
20
Tags
Clock
Game
Timer
Time server
Sntp
Time synchronization
Time clock
Net
Windows
Software
Featured stories
See all
Bitcoin hits $16,000 - it's time to mine
The value for Bitcoins is going through the roof stabilizing at $16,000 after reaching a record peak of $18,000 earlier today. This means that Bitcoin mining might be a good idea.
Best time-management tools to use in 2022
We’ve rounded up the best time-management software available to organize your time more efficiently and work more effectively.
Meta bets on AI big time, according to Zuckerberg
Meta seeks to dominate in the race for Artificial General Intelligence, as confirmed by Mark Zuckerberg in his Threads video.
Fun time! Here’s how to boost your PC for gaming (basic tweaks)
Want your gaming sessions to be more memorable and fun? Here are some basic tips that will help you achieve the desired effect without much tinkering around.
Fun time! Here’s how to boost your PC for gaming (advanced hacks)
Here is some more advice about how to boost the performance of your computer for gaming purposes. This set has more advanced tricks.